Welcome to Project: Gorgon!


Project: Gorgon is a 3D fantasy MMORPG (massively-multiplayer online role-playing game) that features an immersive experience that allows the player to forge their own path through exploration and discovery. We won't be guiding you through a world on rails, and as a result there are many hidden secrets awaiting discovery. Project: Gorgon also features an ambitious skill based leveling system that bucks the current trend of pre-determined classes, thus allowing the player to combine skills in order to create a truly unique playing experience.

The Project: Gorgon development team is led by industry veteran Eric Heimburg. Eric has over a decade of experience working as a Senior and Lead Engineer, Developer, Designer and Producer on successful games such as Asheron’s Call 1 and 2, Star Trek Online and other successful Massively Multiplayer Online Games.



User Tag List

Results 1 to 10 of 10
  1. #1
    Member Celedor's Avatar
    Join Date
    Jun 2017
    Location
    Ottawa, Canada
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    205 (0 Banked)

    Cannot connect to server

    When I try run the launcher, I'm getting this message in the upper left the window:
    ---
    Project: Gorgon news does not seem to be available right now.
    Error: Couldn't connect to server
    ---

    In the lower part of the window, it says (in red):
    ---
    Could not download asset version file!
    File: http://client.projectgorgon.com/fileversion.txt
    Error: Couldn't connect to server
    ---

    The same thing was happening last night, so I just figured the server was down. But I get it this morning too. And from posts in these forums, others seem to have connected in that time. I have also manually followed that URL, and I can access the file (it just says "292").

    Any ideas on how to fix this? Something preferably other than "try re-downloading the game", because it takes me about 8 hours to download.

    Celedor

  2.   Click here to go to the next staff post in this thread.   #2
    Administrator Silvonis's Avatar
    Join Date
    Feb 2016
    Posts
    315
    Blog Entries
    5
    Mentioned
    21 Post(s)
    Tagged
    2 Thread(s)
    Points
    1,359 (0 Banked)
    Awards Backer Club
    Just to confirm, do you have Launcher v7? When was the last time you were able to play?

  3. #3
    Member Celedor's Avatar
    Join Date
    Jun 2017
    Location
    Ottawa, Canada
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    205 (0 Banked)
    I'm pretty sure I was able to play yesterday morning. If not, then definitely the day before.

    How do I tell what version I have?

    When I look at the "properties" of the launcher, it says it was created on June 29, 2017.
    But under "previous versions" it includes one from December 16, 2017.
    In Windows Explorer, it says it was last modified on November 23, 2017.

  4. #4
    Member Celedor's Avatar
    Join Date
    Jun 2017
    Location
    Ottawa, Canada
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    205 (0 Banked)
    OK, now I'm seeing different information. No previous versions, and current version of ProjectGorgonLauncherWin is 5.6.3.37608, modified on November 23, 2017. Something strange is happening, because I had no problems playing a day or two ago and nothing has happened since then. I'll investigate further.

    Thanks for your time.

  5. #5
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    594
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Points
    241 (1,801 Banked)
    I think the server may be having problems this morning. I logged in originally about half an hour ago. Everything was fine at the time, then when I logged out, the news and event tabs in the login screen were blank. I logged in again anyway and seem to be ok inside the game, but if I start the launcher again, it gives me the same error as Celedor above.

    That's using the latest experimental Linux launcher. On my other computer, it's stuck on "Determine current launcher version" on shardragon's launcher, and trying to download the latest launcher from the forum timed out for me initially.

    Update: After the 5 minutes I spent typing this, all launchers and downloads work again. For now.

  6.   Click here to go to the next staff post in this thread.   #6
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    354
    Blog Entries
    20
    Mentioned
    48 Post(s)
    Tagged
    2 Thread(s)
    Points
    1,624 (0 Banked)
    That doesn't seem like quite the same problem as the other person had. The client can't reach client.projectgorgon.com, but your web browser can. Hm. Are you using a proxy on your web browser? (I'm guessing not, but just checking.)

    I uploaded a new version of the launcher this morning -- it's still displayed as v7 when you run it, though the logs will show the right version of v7.11. The only thing that's changed is there is some more debug-logging to help diagnose problems. Please grab it from

    http://forum.projectgorgon.com/downl...auncherWin.zip

    and run it. If you still have the same problem, please look in the subdirectory ProjectGorgonLauncherWin_Data (it will be in the same place you unzipped the zip). There will be a log file called output_log.txt. If you can email that to me at eric@projectgorgon.com, there might be a clue in there. Thanks!

    (Oh, and regarding versions -- when you use Explorer to look at Properties of the launcher, that actually just shows the version of Unity that was used to compile the launcher. So both of the "v7" builds will have that version of 5.6.3.37608, because I haven't changed my Unity version in between builds.)

  7.   Click here to go to the next staff post in this thread.   #7
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    354
    Blog Entries
    20
    Mentioned
    48 Post(s)
    Tagged
    2 Thread(s)
    Points
    1,624 (0 Banked)
    @Tagamogi - that was just me. After reading this thread, I took client.projectgorgon.com offline for a half-hour or so this morning while I did some checking and tweaking. But no smoking guns found.

    As of 11:15am EDT everything should be back online now!

  8. #8
    Member Celedor's Avatar
    Join Date
    Jun 2017
    Location
    Ottawa, Canada
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    205 (0 Banked)
    *sigh* It looks like Norton is removing the current launcher automatically. It removed it when I unzipped it, but I restored it. Then it seemed to remove it again when I tried to run it. So the problem is at my end (unless that Download Insight thing is not meant to be there).

    Edit: I managed to add the launcher to the exceptions and I seem to be running the latest version. But I'm still getting that error. I emailed the log to Eric.
    Last edited by Celedor; 12-22-2017 at 10:52 AM.

  9.   This is the last staff post in this thread.   #9
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    354
    Blog Entries
    20
    Mentioned
    48 Post(s)
    Tagged
    2 Thread(s)
    Points
    1,624 (0 Banked)
    Ah, yeah Norton has been trouble for us before. They seem to think every new version of our launcher is a trojan horse, just on principle that it's not the same as the old version. It's very annoying.

    Norton's firewall may also be responsible for the launcher being unable to connect to the net. Since your browser can read http://client.projectgorgon.com/fileversion.txt but the launcher can't reach it at all, that tells me that either your browser is set up in a special way to access the internet (which is unlikely), or some software is firewalling the launcher so it can't access web pages. See if turning off all firewalls for a few minutes allows the launcher to work.

    (I mentioned this in email but wanted to repeat it, in case other people are having the same issue.)

  10. #10
    Member Celedor's Avatar
    Join Date
    Jun 2017
    Location
    Ottawa, Canada
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    205 (0 Banked)
    That was it, the Norton firewall. Turned it off, I could connect. Turned it back on, I couldn't.

    Thanks for all your help!



Thread Footer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •