Welcome to Project: Gorgon!


Project: Gorgon is a 3D fantasy MMORPG (massively-multiplayer online role-playing game) that features an immersive experience that allows the player to forge their own path through exploration and discovery. We won't be guiding you through a world on rails, and as a result there are many hidden secrets awaiting discovery. Project: Gorgon also features an ambitious skill based leveling system that bucks the current trend of pre-determined classes, thus allowing the player to combine skills in order to create a truly unique playing experience.

The Project: Gorgon development team is led by industry veteran Eric Heimburg. Eric has over a decade of experience working as a Senior and Lead Engineer, Developer, Designer and Producer on successful games such as Asheron’s Call 1 and 2, Star Trek Online and other successful Massively Multiplayer Online Games.



User Tag List

Results 1 to 5 of 5
Thread: Zoning Lag
  1. #1
    Member Figger1's Avatar
    Join Date
    Jan 2019
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    536 (0 Banked)

    Zoning Lag

    When I change zones, it often shows "not responding" for a minute then it starts to load the next zone. Is that normal or am I put into a queue and i have to wait my turn? Or is there some setting that will stop that from happening? Does this happen to anyone else?

  2. #2
    Senior Member ShieldBreaker's Avatar
    Join Date
    Dec 2016
    Posts
    838
    Mentioned
    22 Post(s)
    Tagged
    2 Thread(s)
    Points
    154 (2,506 Banked)
    https://forum.projectgorgon.com/show...s-April-7-2018
    A new special setting, MaxActiveLoads, might improve loading times when you enter new areas. Normally the loading screen tries to load up to 10 things at once, but on some computers (maybe most computers?) a different number would be better. The new setting lets you change the maximum number of simultaneous loads. Setting it to MaxActiveLoads=100 would allow up to 100 concurrent loads -- that'd be pretty much maxed out, and could speed up or slow down loading, depending on your machine. (A more practical value to try might be 5 or 20.) You might also try MaxActiveLoads=1 to make it stop multitasking at all -- this will probably be much slower, but it uses much less RAM during startup. If you experiment with this setting please let us know your thoughts after a few weeks' usage.
    It is used in Setting> Special

  3.   This is the last staff post in this thread.   #3
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    438
    Blog Entries
    22
    Mentioned
    62 Post(s)
    Tagged
    3 Thread(s)
    Points
    2,017 (0 Banked)
    The lag you're experiencing is specific to your computer, it's not network-related. In a nutshell, it happens when the game loads blocks of data (from your hard drive) that are too large for your computer to handle elegantly.

    Because of how scenes are built in the Unity engine, the first piece of data we need to load (the scene's terrain) is really massive, and although we tell Unity to do this in a responsive way, if your computer is slower, it can end up being unresponsive. The biggest cause of this is a slow hard drive -- using a faster drive or an SSD will make this unresponsive time much smaller or go away entirely. (The other cause is a slow video card, but in my recent experience the hard drive speed is by far the biggest bottleneck.)

    The setting that Shieldbreaker mentioned may be useful to you in reducing that time window, although it probably won't remove it entirely. The important thing to know, though, is that your computer is NOT locked up, and is NOT doing nothing -- it's just doing something that's taking so much of its processing power that it can't even get around to updating the screen. So reducing that locked-up time may paradoxically not be what you want, because it may make the total load time slightly longer.
    Last edited by Citan; 08-06-2019 at 09:25 AM.

  4. #4
    Junior Member Illmaster's Avatar
    Join Date
    Jul 2018
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    158 (0 Banked)
    Achievements First Post!
    I have been playing PG for a year and I have experienced pretty lengthy load times. I changed the setting to 100 since shieldbreaker responded to your post and I have seen a significantly shorter load times. I play on a laptop with a weak video card but with 16 ram and SSD drive. I always knew my video card was weak so I used the load times to fill up my bourbon or watch TV.

    Figger, thanks for asking this question. Otherwise I would have never known

  5. #5
    Junior Member Tazza's Avatar
    Join Date
    Jul 2019
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    47 (0 Banked)
    It's also a windows related problem.

    I can't speak for Mac users but there is a reason the top 500 supercomputers run Linux, their CPU scheduling is leaps and bounds above windows (also look at even the file system performance of ext4 against ntfs- let alone the dozen other file systems you can chose from on Linux).

    I have never - ever - had 'system not responding' which windows users get day in day out on all manner of applications.

    Edit to Add: as a Surveyor I am given a top of the range laptop for AutoCad and CivilCad (now called Magnet) and of course the first thing I did was install Gorgon. Windows users often forget that Linux users use or have used windows in the past and have moved beyond that OS. Even MS themselves use Linux, where in the past they had the view of "eat your own dogfood" (meaning use the code you wrote).
    Last edited by Tazza; 08-11-2019 at 03:02 AM.



Thread Footer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •