Welcome to Project: Gorgon!


Project: Gorgon is a 3D fantasy MMORPG (massively-multiplayer online role-playing game) that features an immersive experience that allows the player to forge their own path through exploration and discovery. We won't be guiding you through a world on rails, and as a result there are many hidden secrets awaiting discovery. Project: Gorgon also features an ambitious skill based leveling system that bucks the current trend of pre-determined classes, thus allowing the player to combine skills in order to create a truly unique playing experience.

The Project: Gorgon development team is led by industry veteran Eric Heimburg. Eric has over a decade of experience working as a Senior and Lead Engineer, Developer, Designer and Producer on successful games such as Asheron’s Call 1 and 2, Star Trek Online and other successful Massively Multiplayer Online Games.



User Tag List

Page 6 of 6 FirstFirst ... 456
Results 51 to 58 of 58
  1. #51
    Junior Member shardragon's Avatar
    Join Date
    Feb 2017
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    91 (0 Banked)
    Glad to hear!

    Quote Originally Posted by Somniare View Post
    Although I had already gone through the permissions as detailed in your instruction post, the system was still not coming up with the view/run dialogue box.
    That does ring a bell… Could you tell my which system and version (i.e.: Ubuntu 16.04, Fedora 25, …) and, if possible, which desktop environment (i.e.: GNOME, Unity, KDE, …) you are using so that I maybe can reproduce this in a VM? This may be something that is fixable.

    Quote Originally Posted by Somniare View Post
    As someone quite unfamiliar with linux I didn't realise this - but your post telling me that it was trying to read the file rather than run it was very helpful - I have now managed to run it through the terminal.
    By that I suppose you mean typing ./pglauncher into a terminal window opened at the given directory, right?

    Thanks for giving feedback on this!

  2. #52
    Junior Member NeverTooOld's Avatar
    Join Date
    Dec 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    82 (0 Banked)
    Achievements First Post!

    14 July patch vs Linux...

    ..... and the winner is not me

    Linux Mint 18.2
    Python 3.5 with TK interface

    Launcher patched to version 285.

    Click Launch Game

    Switches to full screen. All black no Project Gorgon logo. Sits for a couple of minutes and closes.

    From terminal:

    username@computer ~ $ cd Games
    username@computer ~/Games $ cd Gorgon
    username@computer ~/Games/Gorgon $ ./project-gorgon
    Found path: /home/username/.local/share/../games/project-gorgon/LinuxPlayer/ProjectGorgon
    Mono path[0] = '/home/username/.local/share/../games/project-gorgon/LinuxPlayer/ProjectGorgon_Data/Managed'
    Mono path[1] = '/home/username/.local/share/../games/project-gorgon/LinuxPlayer/ProjectGorgon_Data/Mono'
    Mono config path = '/home/username/.local/share/../games/project-gorgon/LinuxPlayer/ProjectGorgon_Data/Mono/etc'
    Preloaded 'ScreenSelector.so'
    Preloaded 'libCSteamworks.so'
    Preloaded 'libsteam_api.so'
    Player data archive not found at `/home/username/.local/share/../games/project-gorgon/LinuxPlayer/ProjectGorgon_Data/data.unity3d`, using local filesystem
    Run up launcher again. Click Validate Game Data. All appears to check out. No new files downloaded. Problem still exists.

    Problem number 1: The default install stores the Project Gorgon files in /home/username/.local/games/project-gorgon/LinuxPlayer/ProjectGorgon_Data

    Aha, you say: copy /home/username/.local/games and sub-folders to /home/username/.local/share/games. BZZZZZZT wrong!

    So problem number 2a: /home/username/.local/gamesproject-gorgon/LinuxPlayer/ProjectGorgon_Data/data.unity3d does not exist

    Problem 2b data.unity3d does not exist in any folder under /home/username/

    Problem 2c data.unity3d does not exist anywhere in the file system

  3. #53
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    257
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Points
    60 (872 Banked)
    For what it's worth, I've been seeing the same "Player data archive not found" message as NeverTooOld. However, my game looks like it is starting but that my monitor is maybe a quarter of the size of what it's expecting. I can see a black screen with the Project Gorgon logo in the corner, but it looks like the actual login prompt is somewhere offscreen for me.

    I shut down the game with Ctrl-C, so I'm uncertain whether it would have closed on its own.

    I don't know if this is actually a problem with the launcher or maybe with the game itself. I haven't had the time to do any serious troubleshooting.

  4. #54
    Junior Member SausageJavelins's Avatar
    Join Date
    Feb 2017
    Location
    USA
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    107 (0 Banked)
    Achievements First Post!
    I am experiencing the same problem. Black screen upon starting the game from terminal with the same error output.


    The log file contains some interesting errors.

    (EDIT)
    Sent in the log file, hopefully it is a quick and easy fix.
    Last edited by SausageJavelins; 07-17-2017 at 12:50 PM.

  5. #55
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    257
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Points
    60 (872 Banked)
    For me, the problem was simply that the login screen will not display correctly in full screen mode. I renamed my preferences file ( ~/.config/unity3d/Elder Game/Project Gorgon/GorgonConfig.txt ) to something else, PG created a new preferences file for me when I launched and it defaulted to windowed mode which shows the login screen fine for me. I'm still seeing the same error message about "Player data archive not found" but it appears to be harmless.

    Once inside the game, I was able to switch to full screen mode and it worked. Interestingly enough, when I chose "Logout" in the game, it displayed the login screen fine full screen, but when I exited the game completely and restarted it went back to my previous display problem.
    Last edited by Tagamogi; 07-17-2017 at 07:47 PM.

  6. #56
    Junior Member NeverTooOld's Avatar
    Join Date
    Dec 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    82 (0 Banked)
    Achievements First Post!
    Confirming that renaming ~/.config/unity3d/Elder Game/Project Gorgon/GorgonConfig.txt allowed the login screen to render correctly and I could reset to full screen once logged in.

    I have not put all windows back where I had them and have missed a couple of options. A compare of the renamed file and the newly saved preferences shows that the significant difference is the following text is absent in the newly created file:

    i Tip_KickStarter2015_1 0 1
    However, I cannot duplicate the return of the issue from Quit Game. That is, I exited the game with Quit Game and was able to login again without issue.

  7. #57
    Junior Member NeverTooOld's Avatar
    Join Date
    Dec 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    82 (0 Banked)
    Achievements First Post!
    As an exercise in expected masochism, I swapped the new ~/.config/unity3d/Elder Game/Project Gorgon/GorgonConfig.txt with the backed up file ie. restored the previously broken situation.


    I expected a black screen. Instead, the login screen rendered correctly and allowed me to login.

  8. #58
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    257
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Points
    60 (872 Banked)
    Ok, this makes no sense whatsoever. Today, before logging in, I tried the following:

    - Moved my old config file back as the preference file and changed the single line "PrefsFullScreen 0 1" to "PrefsFullScreen 0 0". That displayed the login screen fine in windowed mode.

    - I then quit the game and edited the line back to say "PrefsFullScreen 0 1". And that displayed the login screen fine in fullscreen mode.

    I have no idea why that would work but I guess I'm just going to go play...

    Edit:
    I just repeated this process on my second computer. On that computer, I confirmed first that I still got the broken login screen when I tried to log in initially today. The only difference between my initial non-working pref file and the current pref file is the last login time.
    Last edited by Tagamogi; 07-18-2017 at 07:57 PM.



Thread Footer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •