Welcome to Project: Gorgon!


Project: Gorgon is a 3D fantasy MMORPG (massively-multiplayer online role-playing game) that features an immersive experience that allows the player to forge their own path through exploration and discovery. We won't be guiding you through a world on rails, and as a result there are many hidden secrets awaiting discovery. Project: Gorgon also features an ambitious skill based leveling system that bucks the current trend of pre-determined classes, thus allowing the player to combine skills in order to create a truly unique playing experience.

The Project: Gorgon development team is led by industry veteran Eric Heimburg. Eric has over a decade of experience working as a Senior and Lead Engineer, Developer, Designer and Producer on successful games such as Asheron’s Call 1 and 2, Star Trek Online and other successful Massively Multiplayer Online Games.



User Tag List

Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 74
  1. #21
    Junior Member HiFiWiFi's Avatar
    Join Date
    Feb 2017
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    79 (0 Banked)
    Hi guys, just wondering where the files are downloaded and installed to, having trouble finding them, and the launcher redownloads all the files every time I uses it.

  2. #22
    Senior Member alleryn's Avatar
    Join Date
    Jan 2017
    Posts
    272
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    Points
    978 (0 Banked)
    Quote Originally Posted by HiFiWiFi View Post
    Hi guys, just wondering where the files are downloaded and installed to, having trouble finding them, and the launcher redownloads all the files every time I uses it.
    I guess this would depend on your operating system and settings. My system prompted me for a download location for the launcher, and again when i ran the launcher it asked me for an installation directory for the files.

    Perhaps try doing a file search. For example on my Windows system, the launcher is called ProjectGorgonLauncherWin.exe and the client executable (don't actually execute this manually though, always run the launcher) is called WindowsPlayer.exe

    Hope that helped a little.

    Edit: I guess i should have looked at the thread title before posting...

  3. #23
    Junior Member NeverTooOld's Avatar
    Join Date
    Dec 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    109 (0 Banked)
    Achievements First Post!
    Quote Originally Posted by HiFiWiFi View Post
    Hi guys, just wondering where the files are downloaded and installed to, having trouble finding them, and the launcher redownloads all the files every time I uses it.
    On my Manjaro install the files are in ~/.local/games/project-gorgon

    Cannot answer why the launcher is redownloading.

  4. #24
    Member ShubiMaja's Avatar
    Join Date
    Dec 2016
    Posts
    50
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    308 (0 Banked)
    Quote Originally Posted by HiFiWiFi View Post
    Hi guys, just wondering where the files are downloaded and installed to, having trouble finding them, and the launcher redownloads all the files every time I uses it.
    If you are using ubuntu you can try this

    1. open a terminal with Ctrl + alt + T
    2. type the command to update ur file index: sudo updatedb
    3. type the command to search ur file index: locate project | grep gorgon

    This should give u a list of locations where ur system detected project gorgon files
    The Cows Are Always Watching.

    Spoiler Spoiler:

  5. #25
    Member SausageJavelins's Avatar
    Join Date
    Feb 2017
    Location
    USA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    206 (0 Banked)
    My current CLI output using Debian Testing 4.9.0 after running the latest Gorgon Linux Launcher listed on this thread::

    User interface "tk" not available
    Getting welcome message
    Getting latest pglauncher version
    • pglauncher version:
    - Current: 1.1.3
    - Latest: 1.1.3
    Getting latest vanilla launcher version
    • Launcher version: 6
    Offical launcher version is version 6; however this launcher is only compatible with version 5

    Traceback (most recent call last):
    File "/home/chris/Downloads/pglauncher/pglauncher/ui/cli/main.py", line 62, in run
    self.patcher.patch()
    File "/home/chris/Downloads/pglauncher/pglauncher/patcher.py", line 480, in patch
    raise PatcherOutdated(version_latest)
    pglauncher.patcher.PatcherOutdated: Offical launcher version is version 6; however this launcher is only compatible with version 5

    Press enter to exit…
    I suppose this is being worked on, but I did not see any other posts and did not want to assume. Thanks!


    -SJ

  6. #26
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    556
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Points
    109 (1,801 Banked)
    As a possible quick workaround, I edited the patcher.py file in my pglauncher directory and changed line 78 to:
    PATCHER_LAUNCHER_VERSION = 6

    (from 5). This at least has my client downloading the patch, although I don't know yet whether it is going to actually run or not. I think it may also be downloading everything from scratch, ugh...

    I'm going to grab breakfast and update this post in a bit, depending on how it goes.

  7.   This is the last staff post in this thread.   #27
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    340
    Blog Entries
    19
    Mentioned
    42 Post(s)
    Tagged
    2 Thread(s)
    Points
    1,542 (0 Banked)
    Version 5 and 6 are both compatible, for downloading purposes, so you can just change that number in the config. But there seems like a different minor issue -- I think the launcher software you're using is reading from the wrong version file. It should be reading the file at client.projectgorgon.com/launcherversion_linux.txt , which is still set at 5. I think it's reading launcherversion_win.txt instead.

  8. #28
    Senior Member Tagamogi's Avatar
    Join Date
    Jan 2017
    Posts
    556
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Points
    109 (1,801 Banked)
    Thanks, Citan! I can confirm that my client worked just fine after I changed the launcher version to 6, and I was able to log into the game and play.

    I've updated the github page to make sure shardragon will see it (although I think he's subscribed to this thread now anyway).

    Edit: Until we get an official launcher patch, a better interim fix than the one I originally posted would be to change the way the patcher.py file reads the version from the server in line 443. You can search patcher.py for:

    class LinuxPatcher(Patcher):
    URL_LAUNCHER_VERSION = "http://client.projectgorgon.com/launcherversion_win.txt"
    and change that to
    class LinuxPatcher(Patcher):
    URL_LAUNCHER_VERSION = "http://client.projectgorgon.com/launcherversion_linux.txt"
    And the game should work.

    Edit2: Well, that's embarrassing. I've been using the older command line launcher instead of the new self-patching pglauncher. Finding and editing the patcher.py works fine for my version obviously, but the fancy self-patching pglauncher seems to be all one big binary file? I'd been vaguely assuming it was updating my old patcher directory, but that appears to be incorrect. So, for everyone using the new pglauncher, you may just have to wait on the real patch. Sorry!
    Last edited by Tagamogi; 03-25-2017 at 10:57 AM.

  9. #29
    Junior Member Arindor's Avatar
    Join Date
    Feb 2017
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    122 (0 Banked)
    Quote Originally Posted by Tagamogi View Post
    Edit2: Well, that's embarrassing. I've been using the older command line launcher instead of the new self-patching pglauncher. Finding and editing the patcher.py works fine for my version obviously, but the fancy self-patching pglauncher seems to be all one big binary file? I'd been vaguely assuming it was updating my old patcher directory, but that appears to be incorrect. So, for everyone using the new pglauncher, you may just have to wait on the real patch. Sorry!
    I'm also using the command-line launcher and your suggestion worked great for me. Thanks!

  10. #30
    Member SausageJavelins's Avatar
    Join Date
    Feb 2017
    Location
    USA
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Points
    206 (0 Banked)
    I applied Citan's and Tagamogi's fixes to no avail. It yields the same error message after updating both 'puters to latest Debian Stretch 4.9.0-2-amd64 and despite changing URL_LAUNCHER_VERSION to "..._linux.txt" and PATCHER_LAUNCHER_VERSION to "6" in patcher.py



Thread Footer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •