Welcome to Project: Gorgon!


Project: Gorgon is a 3D fantasy MMORPG (massively-multiplayer online role-playing game) that features an immersive experience that allows the player to forge their own path through exploration and discovery. We won't be guiding you through a world on rails, and as a result there are many hidden secrets awaiting discovery. Project: Gorgon also features an ambitious skill based leveling system that bucks the current trend of pre-determined classes, thus allowing the player to combine skills in order to create a truly unique playing experience.

The Project: Gorgon development team is led by industry veteran Eric Heimburg. Eric has over a decade of experience working as a Senior and Lead Engineer, Developer, Designer and Producer on successful games such as Asheron’s Call 1 and 2, Star Trek Online and other successful Massively Multiplayer Online Games.



User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member Stelawrat's Avatar
    Join Date
    Jan 2018
    Location
    Montreal Quebec
    Posts
    17
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    129 (0 Banked)

    Confirmation Minimum Specs Required Please

    I like this game so much & am able to play it perfectly in the low level areas.

    However, as soon as I travel to Serbul, I begin to experience odd flashing windows when trying to complete transactions. The screen eventually freezes, game becomes non-responsive & I have to CAD out.

    Could someone please confirm that the problem is most likely my laptop specs.

    ASUS X553MA
    Running Windows 10 Home
    Processor - Intel Pentium CPU N3540 @ 2.16GHz 2.16 GHZ
    RAM - 8.00 GB
    System - 64-bit OS, x64-based processor

    Thanks.
    You are a child of the universe, no less than the trees and the stars; you have a right to be here. Desiderata.

  2. #2
    Member Madmatx's Avatar
    Join Date
    Dec 2017
    Posts
    66
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    271 (0 Banked)
    Although they don't specify that you need a graphics card to play the game, it's a bit rough with integrated graphics in my experience. I have a pretty decent laptop with integrated graphics and I had to change the settings pretty low to play with decent FPS on it. Even on my old PC with a GTX 465 that I use for movies in my bedroom I have to leave graphics settings at 0 or 1. On my gaming PC the game runs great at max settings though.

    I would suggest lowering your settings to -2 (retro) and work your way up from there.

    You can press and hold the alt button before hitting the play button in the launcher, continue to hold the alt button until the display options pop up.

    Click here for the official troubleshooting guide for more details

  3. #3
    Junior Member Stelawrat's Avatar
    Join Date
    Jan 2018
    Location
    Montreal Quebec
    Posts
    17
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    129 (0 Banked)
    Thank you for the suggestions Madmatx.

    I had already followed those found in the guide that you link to, including reducing the graphics setting to 0:Bad, which helped but still crashed too often. So I tried reducing it by one more setting but without much effect & it was a bit hard on the eyes. I put them back to 0 & never tried the lower settings after that. I did this using the ingame settings menu though, but I imagine the result would be the same using your method.

    I will give it another shot though. Thanks again.
    You are a child of the universe, no less than the trees and the stars; you have a right to be here. Desiderata.

  4. #4
    Senior Member Crissa's Avatar
    Join Date
    Dec 2016
    Location
    Santa Cruz, CA
    Posts
    861
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Points
    2,057 (750 Banked)
    Hmm...

    Well, I play the game on integrated graphics, an older Intel HD 5000. I don't have any flashing or misplaced graphics.

    Although my chip is an i7, it's slower than your N.

  5.   Click here to go to the next staff post in this thread.   #5
    Administrator Citan's Avatar
    Join Date
    Dec 2016
    Posts
    362
    Blog Entries
    21
    Mentioned
    51 Post(s)
    Tagged
    3 Thread(s)
    Points
    1,707 (0 Banked)
    Just based on the symptoms of UI windows flickering and dying, it sounds like you're running out of video memory. Your N3540 has 8gb of RAM, but only about 1.7gb (1792mb) of that RAM can be used as video memory. It's just a limitation of the chip set. (In contrast, many versions of the i7 that Crissa mentioned can use half of the computer's memory as video memory.)

    If the crashing problems go away when you use the -1 or -2 graphics settings, that's almost certainly what's going on: it's running out of video memory. But if the flickering and crashing still happen, there's probably something else going on -- if you email the logs to me I can take a look! (There's steps for this in the wiki I believe. Finding the log is a little tricky, but once found, you just email it to eric@projectgorgon.com .)

    The other variable here is screen resolution. The smaller the resolution, the less video memory is needed, so you might try making the resolution smaller. If you play in windowed mode, just make the window smaller. If you play full-screen, the Settings window has a list of resolutions your card supports. Two caveats: don't go below 1024x768 resolution, because some UI windows may be too small and blurry to be used! (I need to take those tiny resolutions out of the list.) And if your screen becomes unresponsive when you go into fullscreen mode, it means your computer doesn't actually support that resolution even though it said it did -- press alt+enter to switch out of fullscreen mode and try another. (In the worst case, you can restart the game with "Safe Mode" turned on in the launcher, which will make the game ignore your chosen resolution.)

    Lastly, since video memory seems like your bottleneck, you can manually lower the texture resolution. Choose "0: Bad", then click "Show Advanced Options" and set the "Texture Memory Restriction" to 2. The result will be somewhere between the "-1" and the "0" quality levels, much better than -1 but noticeably worse than 0. That may or may not be something you can tolerate, but worth trying.

    Edit to talk about min-spec: theoretically, that computer should meet the min-specs for the final game. But we still have many months of optimizations left, and the amount of memory used fluctuates with each update. So it's definitely possible that it's not going to be viable during beta. (Although "viable" means running on "0: Bad" settings... I expect you'd be fine on lower settings, if you can stomach it.)

  6. #6
    Member Madmatx's Avatar
    Join Date
    Dec 2017
    Posts
    66
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    271 (0 Banked)
    Quote Originally Posted by Citan View Post
    If you play in windowed mode, just make the window smaller. If you play full-screen, the Settings window has a list of resolutions your card supports.
    Are you saying that if you play in windowed mode that if you maximize the window the resolution setting doesn't apply, it only makes a difference in full screen? Or am I just misintupritating you saying that making your window smaller is easier?

  7. #7
    Senior Member Crissa's Avatar
    Join Date
    Dec 2016
    Location
    Santa Cruz, CA
    Posts
    861
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Points
    2,057 (750 Banked)
    Quote Originally Posted by Madmatx View Post
    Are you saying that if you play in windowed mode that if you maximize the window the resolution setting doesn't apply, it only makes a difference in full screen? Or am I just misintupritating you saying that making your window smaller is easier?
    Yes, changing the window size should just straight up change the resolution. Tho you can do it in the change-resolutions mode, and I haven't had much trouble playing in a small window. (Tho it does get hard to read stuff sometimes)

  8. #8
    Member Madmatx's Avatar
    Join Date
    Dec 2017
    Posts
    66
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    271 (0 Banked)
    I guess you're right. I just lowered my resolution and in windowed mode with a maximized screen everything still looked sharp but in full screen the text got blurry.

  9. #9
    Junior Member Stelawrat's Avatar
    Join Date
    Jan 2018
    Location
    Montreal Quebec
    Posts
    17
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Points
    129 (0 Banked)

    Madmatx,
    Thank you for your trick re: making the display options pop up before entering the game. Very neat & useful.

    Citan,
    "Just based on the symptoms of UI windows flickering and dying, it sounds like you're running out of video memory. Your N3540 has 8gb of RAM, but only about 1.7gb (1792mb) of that RAM can be used as video memory. It's just a limitation of the chip set. (In contrast, many versions of the i7 that Crissa
    mentioned can use half of the computer's memory as video memory.)"

    You're right on the money there Citan. I'm not tech savvy at all, but because I was having problems, I kept task manager running for easy access to end the game. The memory column was always near the max! in the upper 80's even 90's.

    I posted because I was worried that I might damage this comp if I continued to play, pushing the system this way.

    That & also I wondered, was really curious about, how it was that I can play at 1:0 on the island, in all of the environments, without any problems. Play there isn't affected by number of mobs, players, actual time of day. It's just beautiful.

    Re: the chip set, if it's a built in limitation, then I guess the RAM can't be reallocated?

    Re: screen resolution, I prefer to play games in windowed mode. When I checked the options, I understood the game would default to windowed unless that option was disabled. The game launched in what I thought was full screen & I didn't see a way to change that, so thought the option wasn't implemented yet.

    Native resolution is 1366 x 768. After reading this thread last night, changed in game to 1024 x 768. Then I manually resized the window... :/ Did I mention I'm not tech savvy?

    Re: texture resolution, I haven't tried your suggestion yet Citan, but will do today.

    With the changes I've made so far, although reduction in game appearance is significant, it's still really playable & enjoyable for me. Your game is that compelling, that I'd be more than willing to play it anyway.

    Thanks so much for all of this, including the offer to review the logs, in desperation I may take you up on that. :P
    You are a child of the universe, no less than the trees and the stars; you have a right to be here. Desiderata.

  10. #10
    Senior Member Crissa's Avatar
    Join Date
    Dec 2016
    Location
    Santa Cruz, CA
    Posts
    861
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Points
    2,057 (750 Banked)
    Quote Originally Posted by Madmatx View Post
    I guess you're right. I just lowered my resolution and in windowed mode with a maximized screen everything still looked sharp but in full screen the text got blurry.
    Yeah, I think the game forgets to match the text. Because it'll be inconsistent which windows are blurry. Since this happens in the second UI (albeit less often), it may be a Unity problem. Generally, if you reset the resolution settings (hit save) it will clear up if it's gotten blurry. I guess it just forgets to finish them all or something?

    Anyhow, yay that @Stelawrat got back into the game ^-^



Thread Footer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •